GPT-Disks mit herkömmlichem BIOS booten

Aus gegebenem Anlass eine kurze Anleitung für GPT-Platten unter einem herkömmlichen BIOS:

GPT mit U-Efi braucht kein boot-flag.
GPT mit herkömmlichem Bios braucht oft ein boot-flag. Vor allem braucht es aber in fast jedem Fall ein bios_grub flag, bzw bios-boot-partition. Da kommt die 2. Stage von Grub rein (die 1. ist im MBR). Da die 2. Stage von Grub2 nicht in den MBR passt, wird bei MBR-basierten Platten der Rest vom Bootloader direkt hinter dem MBR plaziert . Bei GPT-Platten gibt es diesen Platz nicht. Deshalb brauchen sie eine kleine bios-boot-partition. Hier reichen ein paar kbyte, um aber im Alignment der SSD zu bleiben, sollte man 1 MByte nehmen. Sowohl GParted als auch gdisk kommen mit einer bios-boot-partition klar.

Dazu legt man in GParted eine (unformatierte) Partition an, klickt rechts und weist ihr unter Markierungen bearbeiten das bios_grub flag zu.

In gdisk, lege eine Partiton an und gib ihr den Typ EF02. Jetzt steht der Verwendung einer GPT-Platte mit einem herkömmlichen Bios nichts mehr im Wege.

2 Gedanken zu “GPT-Disks mit herkömmlichem BIOS booten

  1. Hallo Ferdinand- dieser Beitrag ist ja schon etwas älter. Leider habe ich jetzt mit einem Laptop der älteren Art zu tun und bekomme bei der aktuellen Siduction-Revision (last Edition) Probleme. Nach einer fertigen Installation incl. Grub2 auf einer GPT-Platte ohne UEFI- System startet Siduction sehr zögerlich. Bei der Einrichtung des benötigten Bootbereichs als unformatierte Partition hinter dem MBR mache ich anscheinend irgend etwas falsch. Step 2 von Grub2 scheint den reservierten Bereich (Partion) beim starten nicht zu finden- scheint mir jedenfalls so. Der Latop bleibt nach dem Step 1 von Grub2 für ca. 30 Sekunden mit blinkendem Curser stehen bevor er dann zügig weiter startet.
    Anders als wie vermutet kann ich mir das nicht erklären. Wann und wie kann ich den für Grub 2 erforderlichen Festplattenbereich während der Installation von Siduction anlegen, so das Grub 2 ihn während des späteren Bootvorgangs erkennt. Habe mehrere Versuche mit unterschiedlichen Partitionierern (g-parted, gdisk, fdisk…) durch und bekomme diese 30 Sekunden beim Systemstart nicht weg!
    Hast du vielleicht einen Tip / Link dazu für mich?
    Danke im voraus…

    1. Sorry, habe Deinen Post erst jetzt gesehen. Falls das Problem, noch besteht, komm doch bitte in den IRC. Da ist sowas viel einfacher zu lösen.

Schreibe einen Kommentar zu charly heinz Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.